What’s Vulnerable › Vulnerabilities
CVE-2025-33104: IBM WebSphere Application Server cross
- Severity: high (CVSS 7.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-14 · updated 2026-06-17
- Weakness: CWE-79
Description
IBM WebSphere Application Server 8.5 and 9.0 is vulnerable to cross-site scripting. This vulnerability allows users to embed arbitrary JavaScript code in the Web UI thus altering the intended functionality potentially leading to credentials disclosure within a trusted session.
Affected products
- IBM WebSphere Application Server: from 8.5 before 8.5.5.28; from 9.0 before 9.0.5.24 — fixed in 8.5.5.28, 9.0.5.24
How to fix
Upgrade to a fixed version: IBM WebSphere Application Server 8.5.5.28, 9.0.5.24. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-33104 or the next vulnerability affects your stack