What’s Vulnerable › Vulnerabilities
CVE-2025-33142: IBM WebSphere Application Server information disclosure
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-14 · updated 2026-06-17
- Weakness: CWE-295
Description
IBM WebSphere Application Server 8.5 and 9.0 could provide weaker than expected security for TLS connections.
Affected products
- IBM WebSphere Application Server: from 8.5.0.0 before 8.5.5.29; from 9.0.0.0 before 9.0.5.25 — fixed in 8.5.5.29, 9.0.5.25
How to fix
Upgrade to a fixed version: IBM WebSphere Application Server 8.5.5.29, 9.0.5.25. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-33142 or the next vulnerability affects your stack