What’s Vulnerable › Vulnerabilities
CVE-2025-33178
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-11 · updated 2026-10-18
- Weakness: CWE-94
Description
NVIDIA NeMo Framework for all platforms contains a vulnerability in the bert services component where malicious data created by an attacker may cause a code injection. A successful exploit of this vulnerability may lead to Code execution, Escalation of privileges, Information disclosure, and Data tampering.
Affected products
- NVIDIA NeMo Framework: before 2.5.0 — fixed in 2.5.0
How to fix
Upgrade to a fixed version: NVIDIA NeMo Framework 2.5.0. Check the vendor advisory for mitigations.
References
- https://nvd.nist.gov/vuln/detail/CVE-2025-33178
- https://nvidia.custhelp.com/app/answers/detail/a_id/5718
- https://www.cve.org/CVERecord?id=CVE-2025-33178
Get alerted when CVE-2025-33178 or the next vulnerability affects your stack