What’s Vulnerable › Vulnerabilities
CVE-2025-33204
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-25 · updated 2026-10-18
- Weakness: CWE-94
Description
NVIDIA NeMo Framework for all platforms contains a vulnerability in the NLP and LLM components, where malicious data created by an attacker could cause code injection. A successful exploit of this vulnerability may lead to code execution, escalation of privileges, information disclosure, and data tampering.
Affected products
- NVIDIA NeMo Framework: before 2.5.1 — fixed in 2.5.1
How to fix
Upgrade to a fixed version: NVIDIA NeMo Framework 2.5.1. Check the vendor advisory for mitigations.
References
- https://nvd.nist.gov/vuln/detail/CVE-2025-33204
- https://nvidia.custhelp.com/app/answers/detail/a_id/5729
- https://www.cve.org/CVERecord?id=CVE-2025-33204
Get alerted when CVE-2025-33204 or the next vulnerability affects your stack