What’s Vulnerable › Vulnerabilities

CVE-2025-3396: Incorrect Authorization in GitLab

Description

An issue has been discovered in GitLab EE affecting all versions from 13.3 before 17.11.6, 18.0 before 18.0.4, and 18.1 before 18.1.2 that could have allowed authenticated project owners to bypass group-level forking restrictions by manipulating API requests.

Affected products

How to fix

Upgrade to a fixed version: GitLab 17.11.6, 18.0.4, 18.1.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-3396 or the next vulnerability affects your stack