What’s Vulnerable › Vulnerabilities
CVE-2025-34093: Polycom HDX Series Telnet Command Injection via lan traceroute
- Severity: high (CVSS 7.5 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-10 · updated 2026-06-17
- Weakness: CWE-78
Description
An authenticated command injection vulnerability exists in the Polycom HDX Series command shell interface accessible over Telnet. The lan traceroute command in the devcmds console accepts unsanitized input, allowing attackers to execute arbitrary system commands. By injecting shell metacharacters through the traceroute interface, an attacker can achieve remote code execution under the context of the root user. This flaw affects systems where Telnet access is enabled and either unauthenticated access is allowed or credentials are known.
Affected products
- Polycom HDX Series: before 3.1.11 hotfix 2 — fixed in 3.1.11 hotfix 2
How to fix
Upgrade to a fixed version: Polycom HDX Series 3.1.11 hotfix 2. Check the vendor advisory for mitigations.
References
- https://raw.githubusercontent.com/rapid7/metasploit-framework/master/modules/exploits/unix/misc/polycom_hdx_traceroute_exec.rb
- https://staaldraad.github.io/2017/11/12/polycom-hdx-rce/
- https://vulncheck.com/advisories/polycom-hdx-series-telnet-rce
- https://web.archive.org/web/20200312205144/http://support.polycom.com/content/dam/polycom-support/global/documentation/securityadvisory-remotecodeexecutionon-hdx-v0.3-hotfix-release.pdf
- https://www.exploit-db.com/exploits/24494
Get alerted when CVE-2025-34093 or the next vulnerability affects your stack