What’s Vulnerable › Vulnerabilities
CVE-2025-34097: ProcessMaker < 3.5.4 Authenticated Plugin Upload RCE
- Severity: high (CVSS 8.6 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-10 · updated 2026-06-17
- Weakness: CWE-434
Description
An unrestricted file upload vulnerability exists in ProcessMaker versions prior to 3.5.4 due to improper handling of uploaded plugin archives. An attacker with administrative privileges can upload a malicious .tar plugin file containing arbitrary PHP code. Upon installation, the plugin’s install() method is invoked, resulting in execution of attacker-supplied PHP code on the server with the privileges of the web server user. This vulnerability can be chained with CVE-2022-38577 — a privilege escalation flaw in the user profile page — to achieve full remote code execution from a low-privileged account.
Affected products
- ProcessMaker Inc. ProcessMaker: before 3.5.4 — fixed in 3.5.4
How to fix
Upgrade to a fixed version: ProcessMaker Inc. ProcessMaker 3.5.4. Check the vendor advisory for mitigations.
References
- https://process-maker-authenticated-plugin-upload-rce
- https://raw.githubusercontent.com/rapid7/metasploit-framework/master/modules/exploits/multi/http/processmaker_plugin_upload.rb
- https://vulncheck.com/advisories/process-maker-authenticated-plugin-upload-rce
- https://wiki.processmaker.net/3.0/Plugin_Development
- https://www.exploit-db.com/exploits/44399
- https://www.fortiguard.com/encyclopedia/ips/45757
Get alerted when CVE-2025-34097 or the next vulnerability affects your stack