What’s Vulnerable › Vulnerabilities
CVE-2025-34115: OP5 Monitor <= 7.1.9 Authenticated Command Execution via command_test.php
- Severity: high (CVSS 8.7 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-15 · updated 2026-09-08
- Weakness: CWE-20
Description
An authenticated command injection vulnerability exists in OP5 Monitor through version 7.1.9 via the 'cmd_str' parameter in the command_test.php endpoint. A user with access to the web interface can exploit the 'Test this command' feature to execute arbitrary shell commands as the unprivileged web application user. The vulnerability resides in the configuration section of the application and requires valid login credentials with access to the command testing functionality. This issue is fixed in version 7.2.0.
Affected products
- ITRS Group OP5 Monitor: through 7.1.9
References
- https://raw.githubusercontent.com/rapid7/metasploit-framework/master/modules/exploits/linux/http/op5_config_exec.rb
- https://www.exploit-db.com/exploits/39676
- https://www.itrsgroup.com/products/network-monitoring-op5-monitor
- https://www.vulncheck.com/advisories/op5-monitor-authenticated-command-execution
- http://seclists.org/fulldisclosure/2026/Sep/38
Get alerted when CVE-2025-34115 or the next vulnerability affects your stack