What’s Vulnerable › Vulnerabilities
CVE-2025-3414: Structured Content < 1.7.0 - Contributor Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-14 · updated 2026-06-17
Description
The Structured Content (JSON-LD) #wpsc WordPress plugin before 1.7.0 does not validate and escape some of its block options before outputting them back in a page/post where the block is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Affected products
- Gordon Böhme, Antonio Leutsch Structured Content (JSON-LD) #wpsc: before 1.7.0 — fixed in 1.7.0
How to fix
Upgrade to a fixed version: Gordon Böhme, Antonio Leutsch Structured Content (JSON-LD) #wpsc 1.7.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/1dd322b5-3c1d-4da7-8737-e6688fc9f4df/
- https://wpscan.com/vulnerability/1dd322b5-3c1d-4da7-8737-e6688fc9f4df/
Get alerted when CVE-2025-3414 or the next vulnerability affects your stack