What’s Vulnerable › Vulnerabilities
CVE-2025-34141: ETQ Reliance CG < SE.2025.1 Reflected XSS in `SQLConverterServlet`
- Severity: medium (CVSS 5.1 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-07-22 · updated 2026-06-17
- Weakness: CWE-79
Description
A reflected cross-site scripting (XSS) vulnerability exists in ETQ Reliance CG (legacy) platform within the `SQLConverterServlet` component. This vulnerability requires user interaction, such as clicking a crafted link, and may result in execution of unauthorized scripts in the user's context. The affected servlet was unnecessarily exposed to authenticated users and has since been disabled in version SE.2025.1.
Affected products
- ETQ Reliance CG (legacy): before SE.2025.1 — fixed in SE.2025.1
How to fix
Upgrade to a fixed version: ETQ Reliance CG (legacy) SE.2025.1. Check the vendor advisory for mitigations.
References
- https://slcyber.io/assetnote-security-research-center/how-we-accidentally-discovered-a-remote-code-execution-vulnerability-in-etq-reliance/
- https://www.etq.com/blog/etq-reliance-security-update/
- https://www.etq.com/product-overview/
- https://www.vulncheck.com/advisories/etq-reliance-cg-reflected-xss-in-sqlconverterservlet
Get alerted when CVE-2025-34141 or the next vulnerability affects your stack