What’s Vulnerable › Vulnerabilities
CVE-2025-34158
- Severity: high (CVSS 8.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-21 · updated 2026-06-17
- Weakness: CWE-669
Description
Plex Media Server (PMS) 1.41.7.x through 1.42.0.x before 1.42.1 is affected by incorrect resource transfer between spheres because /myplex/account provides the credentials of the server owner (and a /api/resources call reveals other servers accessible by that server owner).
Affected products
- Plex Media Server: from 1.41.7.x before 1.42.1 — fixed in 1.42.1
How to fix
Upgrade to a fixed version: Plex Media Server 1.42.1. Check the vendor advisory for mitigations.
References
- https://forums.plex.tv/t/plex-media-server-security-update/928341
- https://github.com/lufinkey/vulnerability-research/blob/main/CVE-2025-34158/README.md
- https://github.com/lufinkey/vulnerability-research/tree/main/CVE-2025-34158
- https://www.bleepingcomputer.com/news/security/plex-warns-users-to-patch-security-vulnerability-immediately/
- https://www.plex.tv/media-server-downloads/
- https://www.runzero.com/blog/plex/
- https://www.tenable.com/plugins/nessus/250294
- https://www.vulncheck.com/advisories/plex-media-server-unspecified
Get alerted when CVE-2025-34158 or the next vulnerability affects your stack