What’s Vulnerable › Vulnerabilities
CVE-2025-34165: NetSupport Manager < 14.12.0000 Stack-Based Buffer Overflow
- Severity: high (CVSS 8.8 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-30 · updated 2026-10-18
- Weakness: CWE-121
Description
A stack-based buffer overflow vulnerability in NetSupport Manager 14.x versions prior to 14.12.0000 allows a remote, unauthenticated attacker to cause a denial of service (DoS) or potentially leak a limited amount of memory.
Affected products
- NetSupport Ltd. NetSupport Manager: from 14.0 before 14.12.0000 — fixed in 14.12.0000
How to fix
Upgrade to a fixed version: NetSupport Ltd. NetSupport Manager 14.12.0000. Check the vendor advisory for mitigations.
References
- https://www.netsupportmanager.com/
- https://www.vulncheck.com/advisories/netsupport-client-manager-buffer-overflows
Get alerted when CVE-2025-34165 or the next vulnerability affects your stack