What’s Vulnerable › Vulnerabilities
CVE-2025-34172: Netgate pfSense CE HAProxy Package 0.63_10 Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-09 · updated 2026-07-14
- Weakness: CWE-79
Description
In pfSense CE /usr/local/www/haproxy/haproxy_stats.php, the value of the showsticktablecontent parameter is displayed after being read from HTTP GET requests. This can enable reflected cross-site scripting when the victim is authenticated.
Affected products
- Netgate pfSense CE: before 2.8.0 — fixed in 2.8.0
How to fix
Upgrade to a fixed version: Netgate pfSense CE 2.8.0. Check the vendor advisory for mitigations.
References
- https://github.com/pfsense/FreeBSD-ports/commit/04d1328ab077830eb57a24bb7018c812b6358c64
- https://redmine.pfsense.org/issues/16411
- https://www.vulncheck.com/advisories/netgate-pf-sense-ce-ha-proxy-reflected-xss
Get alerted when CVE-2025-34172 or the next vulnerability affects your stack