What’s Vulnerable › Vulnerabilities
CVE-2025-34173: Netgate pfSense CE Snort package v4.1.6_25 Directory Traversal Information Disclosure
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-09 · updated 2026-07-14
- Weakness: CWE-22
Description
In pfSense CE /usr/local/www/snort/snort_ip_reputation.php, the value of the iplist parameter is not sanitized of directory traversal-related characters/strings before being used to check if a file exists. While the contents of the file cannot be read, the server reveals whether a file exists, which allows an attacker to enumerate files on the target. The attacker must be authenticated with at least "WebCfg - Services: Snort package" permissions.
Affected products
- Netgate pfSense CE: before 2.8.0 — fixed in 2.8.0
How to fix
Upgrade to a fixed version: Netgate pfSense CE 2.8.0. Check the vendor advisory for mitigations.
References
- https://github.com/pfsense/FreeBSD-ports/commit/d6f462bcc446969f8955c16cfde300d5c9ab7435
- https://redmine.pfsense.org/issues/16412
- https://www.vulncheck.com/advisories/netgate-pf-sense-ce-snort-directory-traversal-information-disclosure
Get alerted when CVE-2025-34173 or the next vulnerability affects your stack