What’s Vulnerable › Vulnerabilities
CVE-2025-34175: Netgate pfSense CE Suricata package v7.0.8_2 Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 21.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-09 · updated 2026-07-14
- Weakness: CWE-79
Description
In pfSense CE /usr/local/www/suricata/suricata_filecheck.php, the value of the filehash parameter is directly displayed without sanitizing for HTML-related characters/strings. This can result in reflected cross-site scripting if the victim is authenticated.
Affected products
- Netgate pfSense CE: before 2.8.0 — fixed in 2.8.0
How to fix
Upgrade to a fixed version: Netgate pfSense CE 2.8.0. Check the vendor advisory for mitigations.
References
- https://github.com/pfsense/FreeBSD-ports/commit/97852ccfd201b24ee542be30af81272485fde0b4
- https://redmine.pfsense.org/issues/16414
- https://www.vulncheck.com/advisories/netgate-pf-sense-ce-suricata-reflected-xss
Get alerted when CVE-2025-34175 or the next vulnerability affects your stack