What’s Vulnerable › Vulnerabilities
CVE-2025-34182: Deciso OPNsense < 25.7.4 /interfaces_ppps_edit.php ptpid Stored XSS
- Severity: medium (CVSS 5.1 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-01 · updated 2026-10-12
- Weakness: CWE-79
Description
In Deciso OPNsense before 25.7.4, when creating an "Interfaces: Devices: Point-to-Point" entry, the value of the parameter ptpid is not sanitized of HTML-related characters/strings. This value is directly displayed when visiting the page/interfaces_assign.php, which can result in stored cross-site scripting. The attacker must be authenticated with at-least "Interfaces: PPPs: Edit" permission. This vulnerability has been addressed by the vendor in the product release notes as "ui: legacy_html_escape_form_data() was not escaping keys only data elements."
Affected products
- Deciso OPNsense: before 25.7.4 — fixed in 25.7.4
How to fix
Upgrade to a fixed version: Deciso OPNsense 25.7.4. Check the vendor advisory for mitigations.
References
- https://docs.opnsense.org/releases/CE_25.7.html#september-30-2025
- https://www.vulncheck.com/advisories/decisio-opnsense-stored-xss
Get alerted when CVE-2025-34182 or the next vulnerability affects your stack