What’s Vulnerable › Vulnerabilities
CVE-2025-3419: Event Manager, Events Calendar, Tickets, Registrations – Eventin <= 4.0.26 - Unauthenticated Arbitrary File Read
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-08 · updated 2026-06-17
- Weakness: CWE-73
Description
The Event Manager, Events Calendar, Tickets, Registrations – Eventin plugin for WordPress is vulnerable to arbitrary file read in all versions up to, and including, 4.0.26 via the proxy_image() function. This makes it possible for unauthenticated attackers to read the contents of arbitrary files on the server, which can contain sensitive information. CVE-2025-47445 is a duplicate of this vulnerability.
Affected products
- arraytics Eventin – Event Calendar, Event Registration, Tickets & Booking (AI Powered): before 4.0.27 — fixed in 4.0.27
How to fix
Upgrade to a fixed version: arraytics Eventin – Event Calendar, Event Registration, Tickets & Booking (AI Powered) 4.0.27. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3284545/wp-event-solution/trunk/core/Admin/Hooks.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/1479071c-85c3-41fd-8ad7-f0dee32f201b?source=cve
Get alerted when CVE-2025-3419 or the next vulnerability affects your stack