What’s Vulnerable › Vulnerabilities
CVE-2025-34191: Vasion Print (formerly PrinterLogic) Arbitrary File Write as Root via Response Path Symlink Follow
- Severity: high (CVSS 8.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-09-19 · updated 2026-10-18
- Weakness: CWE-59
Description
Vasion Print (formerly PrinterLogic) Virtual Appliance Host versions prior to 22.0.843 and Application prior to 20.0.1923 (macOS/Linux client deployments) contain an arbitrary file write vulnerability via the response file handling. When tasks produce output the service writes response data into files under /opt/PrinterInstallerClient/tmp/responses/ reusing the requested filename. The service follows symbolic links in the responses directory and writes as the service user (typically root), allowing a local, unprivileged user to cause the service to overwrite or create arbitrary files on the filesystem as root. This can be used to modify configuration files, replace or inject binaries or drivers, and otherwise achieve local privilege escalation and full system compromise. This vulnerability has been identified by the vendor as: V-2023-019 — Arbitrary File Write as Root.
Affected products
- Vasion Virtual Appliance Application: before 20.0.1923 — fixed in 20.0.1923
- Vasion Virtual Appliance Host: before 22.0.843 — fixed in 22.0.843
How to fix
Upgrade to a fixed version: Vasion Virtual Appliance Application 20.0.1923; Vasion Virtual Appliance Host 22.0.843. Check the vendor advisory for mitigations.
References
- https://help.printerlogic.com/saas/Print/Security/Security-Bulletins.htm
- https://help.printerlogic.com/va/Print/Security/Security-Bulletins.htm
- https://pierrekim.github.io/blog/2025-04-08-vasion-printerlogic-83-vulnerabilities.html#mac-arbitrary-file-write
- https://www.vulncheck.com/advisories/vasion-print-printerlogic-arbitrary-file-write-as-root-via-response-path-symlink-follow
Get alerted when CVE-2025-34191 or the next vulnerability affects your stack