What’s Vulnerable › Vulnerabilities
CVE-2025-34192: Vasion Print (formerly PrinterLogic) Usage of Outdated and Unsupported OpenSSL Version
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-09-19 · updated 2026-10-18
- Weakness: CWE-1104
Description
Vasion Print (formerly PrinterLogic) Virtual Appliance Host versions prior to 22.0.893 and Application versions prior to 20.0.2140 (macOS/Linux client deployments) are built against OpenSSL 1.0.2h-fips (released May 2016), which has been end-of-life since 2019 and is no longer supported by the OpenSSL project. Continued use of this outdated cryptographic library exposes deployments to known vulnerabilities that are no longer patched, weakening the overall security posture. Affected daemons may emit deprecation warnings and rely on cryptographic components with unresolved security flaws, potentially enabling attackers to exploit weaknesses in TLS/SSL processing or cryptographic operations. This vulnerability has been identified by the vendor as: V-2023-021 — Out-of-Date OpenSSL Library.
Affected products
- Vasion Virtual Appliance Application: before 20.0.2140 — fixed in 20.0.2140
- Vasion Virtual Appliance Host: before 22.0.893 — fixed in 22.0.893
How to fix
Upgrade to a fixed version: Vasion Virtual Appliance Application 20.0.2140; Vasion Virtual Appliance Host 22.0.893. Check the vendor advisory for mitigations.
References
- https://help.printerlogic.com/saas/Print/Security/Security-Bulletins.htm
- https://help.printerlogic.com/va/Print/Security/Security-Bulletins.htm
- https://pierrekim.github.io/blog/2025-04-08-vasion-printerlogic-83-vulnerabilities.html#mac-outdated-openssl
- https://www.vulncheck.com/advisories/vasion-print-printerlogic-usage-of-outdated-and-unsupported-openssl-version
Get alerted when CVE-2025-34192 or the next vulnerability affects your stack