What’s Vulnerable › Vulnerabilities
CVE-2025-34207: Vasion Print (formerly PrinterLogic) Insecure SSH Client Configuration
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-29 · updated 2026-10-18
- Weakness: CWE-306
Description
Vasion Print (formerly PrinterLogic) Virtual Appliance Host prior to 22.0.1049 and Application prior to 20.0.2786 (VA and SaaS deployments) configure the SSH client within Docker instances with the following options: `UserKnownHostsFile=/dev/null`, `StrictHostKeyChecking=no`, and `ForwardAgent yes`. These settings disable verification of the remote host’s SSH key and automatically forward the developer’s SSH‑agent to any host that matches the configured wildcard patterns. As a result, an attacker who can reach a single compromised container can cause the container to connect to a malicious SSH server, capture the forwarded private keys, and use those keys for unrestricted lateral movement across the environment. This vulnerability has been identified by the vendor as: V-2024-027 — Insecure Secure Shell (SSH) Configuration.
Affected products
- Vasion Virtual Appliance Application: before 20.0.2786 — fixed in 20.0.2786
- Vasion Virtual Appliance Host: before 22.0.1049 — fixed in 22.0.1049
How to fix
Upgrade to a fixed version: Vasion Virtual Appliance Application 20.0.2786; Vasion Virtual Appliance Host 22.0.1049. Check the vendor advisory for mitigations.
References
- https://help.printerlogic.com/saas/Print/Security/Security-Bulletins.htm
- https://help.printerlogic.com/va/Print/Security/Security-Bulletins.htm
- https://pierrekim.github.io/blog/2025-04-08-vasion-printerlogic-83-vulnerabilities.html#va-insecure-ssh-config
- https://www.vulncheck.com/advisories/vasion-print-printerlogic-insecure-ssh-client-config
- https://pierrekim.github.io/blog/2025-04-08-vasion-printerlogic-83-vulnerabilities.html#va-insecure-ssh-config
Get alerted when CVE-2025-34207 or the next vulnerability affects your stack