What’s Vulnerable › Vulnerabilities
CVE-2025-3422: Everest Forms <= 3.1.1 - Authenticated (Subscriber+) Arbitrary Shortcode Execution
- Severity: medium (CVSS 6.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-11 · updated 2026-06-17
- Weakness: CWE-94
Description
The The Everest Forms – Contact Form, Quiz, Survey, Newsletter & Payment Form Builder for WordPress plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up to, and including, 3.1.1. This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for authenticated attackers, with Subscriber-level access and above, to execute arbitrary shortcodes.
Affected products
- wpeverest Everest Forms – Contact Form, Payment Form, Quiz, Survey & Custom Form Builder: before 3.1.2 — fixed in 3.1.2
How to fix
Upgrade to a fixed version: wpeverest Everest Forms – Contact Form, Payment Form, Quiz, Survey & Custom Form Builder 3.1.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3268742/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/3db1d9a0-ea68-4979-a36d-864c649f7aca?source=cve
Get alerted when CVE-2025-3422 or the next vulnerability affects your stack