What’s Vulnerable › Vulnerabilities
CVE-2025-34223: Vasion Print (formerly PrinterLogic) Insecure Installation Credentials
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-09-29 · updated 2026-10-18
- Weakness: CWE-306
Description
Vasion Print (formerly PrinterLogic) Virtual Appliance Host prior to version 22.0.1049 and Application prior to version 20.0.2786 (VA/SaaS deployments) contain a default admin account and an installation‑time endpoint at `/admin/query/update_database.php` that can be accessed without authentication. An attacker who can reach the installation web interface can POST arbitrary `root_user` and `root_password` values, causing the script to replace the default admin credentials with attacker‑controlled ones. The script also contains hard‑coded SHA‑512 and SHA‑1 hashes of the default password, allowing the attacker to bypass password‑policy validation. As a result, an unauthenticated remote attacker can obtain full administrative control of the system during the initial setup. This vulnerability has been identified by the vendor as: V-2024-022 — Insecure Installation Credentials.
Affected products
- Vasion Virtual Appliance Application: before 20.0.2786 — fixed in 20.0.2786
- Vasion Virtual Appliance Host: before 22.0.1049 — fixed in 22.0.1049
How to fix
Upgrade to a fixed version: Vasion Virtual Appliance Application 20.0.2786; Vasion Virtual Appliance Host 22.0.1049. Check the vendor advisory for mitigations.
References
- https://help.printerlogic.com/saas/Print/Security/Security-Bulletins.htm
- https://help.printerlogic.com/va/Print/Security/Security-Bulletins.htm
- https://pierrekim.github.io/blog/2025-04-08-vasion-printerlogic-83-vulnerabilities.html#va-insecure-credentials-installation
- https://www.vulncheck.com/advisories/vasion-print-printerlogic-insecure-installation-credentials
- https://pierrekim.github.io/blog/2025-04-08-vasion-printerlogic-83-vulnerabilities.html#va-insecure-credentials-installation
Get alerted when CVE-2025-34223 or the next vulnerability affects your stack