What’s Vulnerable › Vulnerabilities
CVE-2025-34253: D-Link Nuclias Connect <= v1.3.1.4 Stored Cross-Site Scripting (XSS)
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-16 · updated 2026-10-29
- Weakness: CWE-79
Description
D-Link Nuclias Connect firmware versions <= 1.3.1.4 contain a stored cross-site scripting (XSS) vulnerability due to improper sanitization of the 'Network' field when editing the configuration, creating a profile, and adding a network. An authenticated attacker can inject arbitrary JavaScript to be executed in the context of other users viewing the profile entry. NOTE: D-Link fixed this issue in version 1.3.1.5.
Affected products
- D-Link Nuclias Connect: through 1.3.1.4
- D-Link Nuclias Connect: before 1.3.1.5 — fixed in 1.3.1.5
How to fix
Upgrade to a fixed version: D-Link Nuclias Connect 1.3.1.5. Check the vendor advisory for mitigations.
References
- https://supportannouncement.us.dlink.com/security/publication.aspx?name=SAP10472
- https://www.dlink.com/en/for-business/nuclias/nuclias-connect
- https://www.vulncheck.com/advisories/dlink-nuclias-connect-stored-xss
Get alerted when CVE-2025-34253 or the next vulnerability affects your stack