What’s Vulnerable › Vulnerabilities
CVE-2025-34267: Flowise Authenticated Command Execution and Sandbox Bypass via Puppeteer & Playwright Packages
- Severity: critical (CVSS 9.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-10-14 · updated 2026-10-08
- Weakness: CWE-77
Description
Flowise v3.0.1 < 3.0.8 and all versions after with 'ALLOW_BUILTIN_DEP' enabled contain an authenticated remote code execution vulnerability and node VM sandbox escape due to insecure use of integrated modules (Puppeteer and Playwright) within the nodevm execution environment. An authenticated attacker able to create or run a tool that leverages Puppeteer/Playwright can specify attacker-controlled browser binary paths and parameters. When the tool executes, the attacker-controlled executable/parameters are run on the host and circumvent the intended nodevm sandbox restrictions, resulting in execution of arbitrary code in the context of the host. This vulnerability was incorrectly assigned as a duplicate CVE-2025-26319 by the developers and should be considered distinct from that identifier.
Affected products
- FlowiseAI Flowise: from 3.0.1 before 3.0.8 — fixed in 3.0.8
How to fix
Upgrade to a fixed version: FlowiseAI Flowise 3.0.8. Check the vendor advisory for mitigations.
References
- https://flowiseai.com/
- https://github.com/FlowiseAI/Flowise/pull/5231
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-5w3r-f6gm-c25w
- https://www.vulncheck.com/advisories/flowise-auth-command-execution-and-sandbox-bypass-via-puppeteer-and-playwright-packages
Get alerted when CVE-2025-34267 or the next vulnerability affects your stack