What’s Vulnerable › Vulnerabilities
CVE-2025-34301: IPFire < v2.29 Stored XSS via Location Group Creation
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-28 · updated 2026-10-19
- Weakness: CWE-79
Description
IPFire versions prior to 2.29 (Core Update 198) contain a stored cross-site scripting (XSS) vulnerability that allows an authenticated attacker to inject arbitrary JavaScript code into the COUNTRY_CODE parameter when creating a location group. When a user adds a new location group, the application issues an HTTP POST request with the ACTION parameter set to savelocationgrp, and the value of the COUNTRY_CODE parameter determines the flag displayed for that group. The value of this parameter is stored and later rendered in the web interface without proper sanitization or encoding, allowing malicious scripts to be executed in the context of other users viewing the affected page.
Affected products
- IPFire.org IPFire: before 2.29; 2.29-core_update183, 2.29-core_update184, 2.29-core_update185, 2.29-core_update186, 2.29-core_update187, 2.29-core_update188 (+9) — fixed in 2.29
How to fix
Upgrade to a fixed version: IPFire.org IPFire 2.29. Check the vendor advisory for mitigations.
References
- https://bugzilla.ipfire.org/show_bug.cgi?id=13876
- https://www.ipfire.org/blog/ipfire-2-29-core-update-198-released
- https://www.vulncheck.com/advisories/ipfire-stored-xss-via-location-group-creation
Get alerted when CVE-2025-34301 or the next vulnerability affects your stack