What’s Vulnerable › Vulnerabilities
CVE-2025-34305: IPFire < v2.29 Stored XSS via Multiple Methods in cleanhtml()
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-28 · updated 2026-10-19
- Weakness: CWE-79
Description
IPFire versions prior to 2.29 (Core Update 198) contain multiple stored cross-site scripting (XSS) vulnerabilities caused by a bug in the cleanhtml() function (/var/ipfire/header.pl) that fails to apply HTML-entity encoding to user input. When an authenticated user submits data to affected endpoints - for example, POST /cgi-bin/wakeonlan.cgi (CLIENT_COMMENT), /cgi-bin/dhcp.cgi (ADVOPT_DATA, FIX_REMARK, FIX_FILENAME, FIX_ROOTPATH), /cgi-bin/connscheduler.cgi (ACTION_COMMENT), /cgi-bin/dnsforward.cgi (REMARK), /cgi-bin/vpnmain.cgi (REMARK), or /cgi-bin/dns.cgi (REMARK) - the application calls escape() and HTML::Entities::encode_entities() but never assigns the sanitized result back to the output variable. The original unsanitized value is therefore stored and later rendered in the web interface without proper sanitation or encoding, allowing injected scripts to execute in the context of other users who view the affected entries.
Affected products
- IPFire.org IPFire: before 2.29; 2.29-core_update183, 2.29-core_update184, 2.29-core_update185, 2.29-core_update186, 2.29-core_update187, 2.29-core_update188 (+9) — fixed in 2.29
How to fix
Upgrade to a fixed version: IPFire.org IPFire 2.29. Check the vendor advisory for mitigations.
References
- https://bugzilla.ipfire.org/show_bug.cgi?id=13880
- https://www.ipfire.org/blog/ipfire-2-29-core-update-198-released
- https://www.vulncheck.com/advisories/ipfire-stored-xss-via-multiple-methods-in-cleanhtml
Get alerted when CVE-2025-34305 or the next vulnerability affects your stack