What’s Vulnerable › Vulnerabilities
CVE-2025-34306: IPFire < v2.29 Stored XSS via Default IP Search Value
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-28 · updated 2026-10-19
- Weakness: CWE-79
Description
IPFire versions prior to 2.29 (Core Update 198) contain a stored cross-site scripting (XSS) vulnerability that allows an authenticated attacker to inject arbitrary JavaScript code through the pienumber parameter when updating the default firewall IP search values. When a user updates these defaults, the application issues an HTTP POST request to /cgi-bin/logs.cgi/firewalllogip.dat with the default number of IPs in the pienumber parameter. The value of this parameter is stored and later rendered in the web interface without proper sanitation or encoding, allowing injected scripts to execute in the context of other users who view the affected page.
Affected products
- IPFire.org IPFire: before 2.29; 2.29-core_update183, 2.29-core_update184, 2.29-core_update185, 2.29-core_update186, 2.29-core_update187, 2.29-core_update188 (+9) — fixed in 2.29
How to fix
Upgrade to a fixed version: IPFire.org IPFire 2.29. Check the vendor advisory for mitigations.
References
- https://bugzilla.ipfire.org/show_bug.cgi?id=13881
- https://www.ipfire.org/blog/ipfire-2-29-core-update-198-released
- https://www.vulncheck.com/advisories/ipfire-stored-xss-via-default-ip-search-value
Get alerted when CVE-2025-34306 or the next vulnerability affects your stack