What’s Vulnerable › Vulnerabilities
CVE-2025-34310: IPFire < v2.29 Stored XSS via Quality of Service (QoS) Settings
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-28 · updated 2026-10-19
- Weakness: CWE-79
Description
IPFire versions prior to 2.29 (Core Update 198) contain a stored cross-site scripting (XSS) vulnerability that allows an authenticated attacker to inject arbitrary JavaScript code through the INC_SPD, OUT_SPD, DEFCLASS_INC, and DEFCLASS_OUT parameters when updating Quality of Service (QoS) settings. When a user updates speeds or classes, the application issues an HTTP POST request to /cgi-bin/qos.cgi and the values for incoming/outgoing speeds and default classes are provided in the INC_SPD, OUT_SPD, DEFCLASS_INC, and DEFCLASS_OUT parameters. The values of these parameters are stored and later rendered in the web interface without proper sanitation or encoding, allowing injected scripts to execute in the context of other users who view the affected QoS entries.
Affected products
- IPFire.org IPFire: before 2.29; 2.29-core_update183, 2.29-core_update184, 2.29-core_update185, 2.29-core_update186, 2.29-core_update187, 2.29-core_update188 (+9) — fixed in 2.29
How to fix
Upgrade to a fixed version: IPFire.org IPFire 2.29. Check the vendor advisory for mitigations.
References
- https://bugzilla.ipfire.org/show_bug.cgi?id=13883
- https://www.ipfire.org/blog/ipfire-2-29-core-update-198-released
- https://www.vulncheck.com/advisories/ipfire-stored-xss-via-quality-of-service-settings
Get alerted when CVE-2025-34310 or the next vulnerability affects your stack