What’s Vulnerable › Vulnerabilities
CVE-2025-34318: IPFire < v2.29 Stored XSS via DNS Creation (proxy.cgi)
- Severity: medium (CVSS 5.1 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-28 · updated 2026-09-26
- Weakness: CWE-79
Description
IPFire versions prior to 2.29 (Core Update 198) contain a stored cross-site scripting (XSS) vulnerability that allows an authenticated attacker to inject arbitrary JavaScript code through the TLS_HOSTNAME, UPSTREAM_USER, UPSTREAM_PASSWORD, ADMIN_MAIL_ADDRESS, and ADMIN_PASSWORD parameters when adding a new DNS entry. When a user adds a DNS entry, the application issues an HTTP POST request to /cgi-bin/dns.cgi and these values are provided in the corresponding parameters. The values are stored and later rendered in the web interface without proper sanitation or encoding, allowing injected scripts to execute in the context of other users who view the affected DNS configuration.
Affected products
- IPFire.org IPFire: before 2.29 (Core Update 198) — fixed in 2.29 (Core Update 198)
How to fix
Upgrade to a fixed version: IPFire.org IPFire 2.29 (Core Update 198). Check the vendor advisory for mitigations.
References
- https://bugzilla.ipfire.org/show_bug.cgi?id=13893
- https://www.ipfire.org/blog/ipfire-2-29-core-update-198-released
- https://www.vulncheck.com/advisories/ipfire-stored-xss-via-dns-creation-proxy-cgi
Get alerted when CVE-2025-34318 or the next vulnerability affects your stack