What’s Vulnerable › Vulnerabilities
CVE-2025-34469: Cowrie < 2.9.0 Unrestricted wget/curl Emulation Enables SSRF-Based DDoS Amplification
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-12-31 · updated 2026-10-08
- Weakness: CWE-918
Description
Cowrie versions prior to 2.9.0 contain a server-side request forgery (SSRF) vulnerability in the emulated shell implementation of wget and curl. In the default emulated shell configuration, these command emulations perform real outbound HTTP requests to attacker-supplied destinations. Because no outbound request rate limiting was enforced, unauthenticated remote attackers could repeatedly invoke these commands to generate unbounded HTTP traffic toward arbitrary third-party targets, allowing the Cowrie honeypot to be abused as a denial-of-service amplification node and masking the attacker’s true source address behind the honeypot’s IP.
Affected products
- Cowrie: before 2.9.0 — fixed in 2.9.0
How to fix
Upgrade to a fixed version: Cowrie 2.9.0. Check the vendor advisory for mitigations.
References
- https://github.com/advisories/GHSA-83jg-m2pm-4jxj
- https://github.com/cowrie/cowrie/issues/2622
- https://github.com/cowrie/cowrie/pull/2800
- https://github.com/cowrie/cowrie/releases/tag/v2.9.0
- https://www.vulncheck.com/advisories/cowrie-unrestricted-wget-curl-emulation-enables-ssrf-based-ddos-amplification
- https://github.com/advisories/GHSA-83jg-m2pm-4jxj
Get alerted when CVE-2025-34469 or the next vulnerability affects your stack