What’s Vulnerable › Vulnerabilities
CVE-2025-3452: SecuPress Free <= 2.3.9 - Missing Authorization to Authenticated (Subscriber+) Arbitrary Plugin Installation
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-29 · updated 2026-06-17
- Weakness: CWE-862
Description
The SecuPress Free — WordPress Security plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'secupress_reinstall_plugins_admin_ajax_cb' function in all versions up to, and including, 2.3.9. This makes it possible for authenticated attackers, with Subscriber-level access and above, to install arbitrary plugins.
Affected products
- SecuPress with Simple SSL – Simple and Performant Security: before 2.3.10 — fixed in 2.3.10
How to fix
Upgrade to a fixed version: SecuPress with Simple SSL – Simple and Performant Security 2.3.10. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/secupress/trunk/free/modules/plugins-themes/tools.php#L686
- https://plugins.trac.wordpress.org/changeset/3283453/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/d9125873-aedd-4334-b8e0-74b67d301904?source=cve
Get alerted when CVE-2025-3452 or the next vulnerability affects your stack