What’s Vulnerable › Vulnerabilities

CVE-2025-34521: Arcserve UDP < 10.2 Reflected Cross-Site Scripting (XSS)

Description

A reflected cross-site scripting (XSS) vulnerability exists in the web interface of the Arcserve Unified Data Protection (UDP), where unsanitized user input is improperly reflected in HTTP responses. This flaw allows remote attackers with low privileges to craft malicious links that, when visited by another user, execute arbitrary JavaScript in the victim’s browser. Successful exploitation may lead to session hijacking, credential theft, or other client-side impacts. The vulnerability requires user interaction and occurs within a shared browser context. This vulnerability affects all UDP versions prior to 10.2. UDP 10.2 includes the necessary patches and requires no action. Versions 8.0 through 10.1 are supported and require either patch application or upgrade to 10.2. Versions 7.x and earlier are unsupported or out of maintenance and must be upgraded to 10.2 to remediate the issue.

Affected products

How to fix

Upgrade to a fixed version: Arcserve Unified Data Protection (UDP) 10.2, 7.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-34521 or the next vulnerability affects your stack