What’s Vulnerable › Vulnerabilities

CVE-2025-34523: Arcserve UDP < 10.2 Pre-Authentication Heap Overflow

Description

A heap-based buffer overflow vulnerability exists in the network-facing input handling routines of Arcserve Unified Data Protection (UDP). This flaw is reachable without authentication and results from improper bounds checking when processing attacker-controlled input. By sending specially crafted data, a remote attacker can corrupt heap memory, potentially causing a denial of service or enabling arbitrary code execution depending on the memory layout and exploitation techniques used. This vulnerability is similar in nature to CVE-2025-34522 but affects a separate code path or component. No user interaction is required, and exploitation occurs in the context of the vulnerable process. This vulnerability affects all UDP versions prior to 10.2. UDP 10.2 includes the necessary patches and requires no action. Versions 8.0 through 10.1 are supported and require either patch application or upgrade to 10.2. Versions 7.x and earlier are unsupported or out of maintenance and must be upgraded to 10.2 to remediate the issue.

Affected products

How to fix

Upgrade to a fixed version: Arcserve Unified Data Protection (UDP) 10.2, 7.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-34523 or the next vulnerability affects your stack