What’s Vulnerable › Vulnerabilities
CVE-2025-3457: Ocean Extra <= 2.4.6 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-22 · updated 2026-06-17
- Weakness: CWE-79
Description
The Ocean Extra plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'oceanwp_icon' shortcode in all versions up to, and including, 2.4.6 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- oceanwp Ocean Extra: before 2.4.7 — fixed in 2.4.7
How to fix
Upgrade to a fixed version: oceanwp Ocean Extra 2.4.7. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/ocean-extra/tags/2.4.5/includes/shortcodes/shortcodes.php#L838
- https://plugins.trac.wordpress.org/changeset/3277977/
- https://themes.trac.wordpress.org/browser/oceanwp/4.0.6/inc/oceanwp-theme-icons.php#L819
- https://themes.trac.wordpress.org/browser/oceanwp/4.0.6/inc/oceanwp-theme-icons.php#L866
- https://www.wordfence.com/threat-intel/vulnerabilities/id/362a01c0-8b97-40dc-8af5-0d904da96576?source=cve
Get alerted when CVE-2025-3457 or the next vulnerability affects your stack