What’s Vulnerable › Vulnerabilities
CVE-2025-3466: Unsanitized Input in langgenius/dify
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-07-07 · updated 2026-06-17
- Weakness: CWE-1100
Description
langgenius/dify versions 1.1.0 to 1.1.2 are vulnerable to unsanitized input in the code node, allowing execution of arbitrary code with full root permissions. The vulnerability arises from the ability to override global functions in JavaScript, such as parseInt, before sandbox security restrictions are imposed. This can lead to unauthorized access to secret keys, internal network servers, and lateral movement within dify.ai. The issue is resolved in version 1.1.3.
Affected products
- langgenius dify: from 1.1.0 before 1.1.3 — fixed in 1.1.3
How to fix
Upgrade to a fixed version: langgenius dify 1.1.3. Check the vendor advisory for mitigations.
References
- https://github.com/langgenius/dify/commit/1be0d26c1feb4bcbbdd2b4ae4eeb25874aadaddb
- https://huntr.com/bounties/f8dc17a3-5536-4944-a680-24070903cd2d
Get alerted when CVE-2025-3466 or the next vulnerability affects your stack