What’s Vulnerable › Vulnerabilities
CVE-2025-3468: NEX-Forms – Ultimate Form Builder – Contact forms and much more <= 8.9.1 - Authenticated (Custom) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-08 · updated 2026-06-17
- Weakness: CWE-79
Description
The NEX-Forms – Ultimate Form Builder – Contact forms and much more plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the clean_html and form_fields parameters in all versions up to, and including, 8.9.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Custom-level access, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- webaways NEX-Forms – Ultimate Forms Plugin for WordPress: before 8.9.2 — fixed in 8.9.2
How to fix
Upgrade to a fixed version: webaways NEX-Forms – Ultimate Forms Plugin for WordPress 8.9.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/nex-forms-express-wp-form-builder/trunk/includes/classes/class.db.php?rev=3226607#L303
- https://www.wordfence.com/threat-intel/vulnerabilities/id/a33a7ba5-c6f8-4cf4-8011-8312e9c5da8f?source=cve
Get alerted when CVE-2025-3468 or the next vulnerability affects your stack