What’s Vulnerable › Vulnerabilities
CVE-2025-3472: Ocean Extra <= 2.4.6 - Unauthenticated Arbitrary Shortcode Execution
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-04-22 · updated 2026-06-17
- Weakness: CWE-94
Description
The Ocean Extra plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up to, and including, 2.4.6. This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes when WooCommerce is also installed and activated.
Affected products
- oceanwp Ocean Extra: before 2.4.7 — fixed in 2.4.7
How to fix
Upgrade to a fixed version: oceanwp Ocean Extra 2.4.7. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/ocean-extra/trunk/includes/shortcodes/shortcodes.php#L618
- https://plugins.trac.wordpress.org/changeset/3277977/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/74428e76-1946-408f-8adc-24ab4b7e46c5?source=cve
Get alerted when CVE-2025-3472 or the next vulnerability affects your stack