What’s Vulnerable › Vulnerabilities
CVE-2025-3479: Forminator <= 1.42.0 - Order Replay Vulnerability
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-17 · updated 2026-06-17
- Weakness: CWE-354
Description
The Forminator Forms – Contact Form, Payment Form & Custom Form Builder plugin for WordPress is vulnerable to Order Replay in all versions up to, and including, 1.42.0 via the 'handle_stripe_single' function due to insufficient validation on a user controlled key. This makes it possible for unauthenticated attackers to reuse a single Stripe PaymentIntent for multiple transactions. Only the first transaction is processed via Stripe, but the plugin sends a successful email message for each transaction, which may trick an administrator into fulfilling each order.
Affected products
- wpmudev Forminator Forms – Contact Form, Payment Form & Custom Form Builder: before 1.42.1 — fixed in 1.42.1
How to fix
Upgrade to a fixed version: wpmudev Forminator Forms – Contact Form, Payment Form & Custom Form Builder 1.42.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/forminator/tags/1.41.2/library/modules/custom-forms/front/front-action.php#L964
- https://plugins.trac.wordpress.org/changeset/3274844/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/c873c04e-516e-41ee-a295-b8c5235abc1b?source=cve
Get alerted when CVE-2025-3479 or the next vulnerability affects your stack