What’s Vulnerable › Vulnerabilities
CVE-2025-3483: MedDream PACS Server DICOM File Parsing Stack-based Buffer Overflow Remote Code Execution Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-22 · updated 2026-06-17
- Weakness: CWE-121
Description
MedDream PACS Server DICOM File Parsing Stack-based Buffer Overflow Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of MedDream PACS Server. Authentication is not required to exploit this vulnerability. The specific flaw exists within the parsing of DICOM files. The issue results from the lack of proper validation of the length of user-supplied data prior to copying it to a fixed-length stack-based buffer. An attacker can leverage this vulnerability to execute code in the context of the service account. Was ZDI-CAN-25825.
Affected products
- MedDream PACS Premium: before 7.3.5.860 — fixed in 7.3.5.860
How to fix
Upgrade to a fixed version: MedDream PACS Premium 7.3.5.860. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-3483 or the next vulnerability affects your stack