What’s Vulnerable › Vulnerabilities
CVE-2025-3488: WPML Multilingual CMS 3.6.0 - 4.7.3 - Authenticated (Contributor+) Stored Cross-Site Scripting via wpml_language_switcher Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-02 · updated 2026-06-17
- Weakness: CWE-79
Description
The WPML plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's wpml_language_switcher shortcode in versions 3.6.0 - 4.7.3 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- OnTheGoSystems Ltd. WPML Multilingual CMS (WordPress plugin): from 3.6.0 before 4.7.4 — fixed in 4.7.4
How to fix
Upgrade to a fixed version: OnTheGoSystems Ltd. WPML Multilingual CMS (WordPress plugin) 4.7.4. Check the vendor advisory for mitigations.
References
- https://wpml.org/category/changelog/
- https://wpml.org/documentation/support/wpml-coding-api/shortcodes/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/92c1bd85-5f81-4bb6-b6af-6cda85b91b9e?source=cve
Get alerted when CVE-2025-3488 or the next vulnerability affects your stack