What’s Vulnerable › Vulnerabilities

CVE-2025-3512: Buffer overflow in QTextMarkdownImporter

Description

There is a Heap-based Buffer Overflow vulnerability in QTextMarkdownImporter. This requires an incorrectly formatted markdown file to be passed to QTextMarkdownImporter to trigger the overflow. This issue affects Qt from 6.8.0 to 6.8.4. Versions up to 6.6.0 are known to be unaffected, and the fix is in 6.8.4 and later.

Affected products

How to fix

Upgrade to a fixed version: Qt 6.8.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-3512 or the next vulnerability affects your stack