What’s Vulnerable › Vulnerabilities

CVE-2025-3525: Allocation of Resources Without Limits or Throttling in GitLab

Description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 9.0 before 18.7.5, 18.8 before 18.8.5, and 18.9 before 18.9.1 that could have, under certain circumstances, allowed an authenticated user with certain access to cause Denial of Service by creating specially crafted CI triggers via the API.

Affected products

How to fix

Upgrade to a fixed version: GitLab 18.7.5, 18.8.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-3525 or the next vulnerability affects your stack