What’s Vulnerable › Vulnerabilities
CVE-2025-3573
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-15 · updated 2026-06-17
- Weakness: CWE-79
Description
Versions of the package jquery-validation before 1.20.0 are vulnerable to Cross-site Scripting (XSS) in the showLabel() function, which may take input from a user-controlled placeholder value. This value will populate a message via $.validator.messages in a user localizable dictionary.
Affected products
- jquery-validation: before 1.20.0 — fixed in 1.20.0
How to fix
Upgrade to a fixed version: jquery-validation 1.20.0. Check the vendor advisory for mitigations.
References
- https://github.com/jquery-validation/jquery-validation/commit/7a490d8f39bd988027568ddcf51755e1f4688902
- https://github.com/jquery-validation/jquery-validation/pull/2462
- https://security.snyk.io/vuln/SNYK-JS-JQUERYVALIDATION-5952285
Get alerted when CVE-2025-3573 or the next vulnerability affects your stack