What’s Vulnerable › Vulnerabilities
CVE-2025-3578: Adversarial Input Handling Vulnerability in AiDex
- Severity: critical (CVSS 9.3 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-15 · updated 2026-06-17
- Weakness: CWE-1039
Description
A malicious, authenticated user in Aidex, versions prior to 1.7, could list credentials of other users, create or modify existing users in the application, list credentials of users in production or development environments. In addition, it would be possible to cause bugs that would result in the exfiltration of sensitive information, such as details about the software or internal system paths. These actions could be carried out through the misuse of LLM Prompt (chatbot) technology, via the /api/<string-chat>/message endpoint, by manipulating the contents of the ‘content’ parameter.
Affected products
- AiDex: before 1.7 — fixed in 1.7
How to fix
Upgrade to a fixed version: AiDex 1.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-3578 or the next vulnerability affects your stack