What’s Vulnerable › Vulnerabilities
CVE-2025-3579: Code Injection Vulnerability in AiDex
- Severity: critical (CVSS 9.3 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-15 · updated 2026-06-17
- Weakness: CWE-94
Description
In versions prior to Aidex 1.7, an authenticated malicious user, taking advantage of an open registry, could execute unauthorised commands within the system. This includes executing operating system (Unix) commands, interacting with internal services such as PHP or MySQL, and even invoking native functions of the framework used, such as Laravel or Symfony. This execution is achieved by Prompt Injection attacks through the /api/<string-chat>/message endpoint, manipulating the content of the ‘content’ parameter.
Affected products
- AiDex: before 1.7 — fixed in 1.7
How to fix
Upgrade to a fixed version: AiDex 1.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-3579 or the next vulnerability affects your stack