What’s Vulnerable › Vulnerabilities
CVE-2025-3581: Newsletter < 8.8.5 - Admin+ Stored XSS via Widget
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-06-09 · updated 2026-06-17
- Weakness: CWE-79
Description
The Newsletter WordPress plugin before 8.8.5 does not validate and escape some of its Widget options before outputting them back in a page/post where the block is embed, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Affected products
- satollo Newsletter – Send awesome emails from WordPress: before 8.8.5 — fixed in 8.8.5
How to fix
Upgrade to a fixed version: satollo Newsletter – Send awesome emails from WordPress 8.8.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/2d96f018-510d-40ab-9e73-76fa44784813/
- https://wpscan.com/vulnerability/2d96f018-510d-40ab-9e73-76fa44784813/
Get alerted when CVE-2025-3581 or the next vulnerability affects your stack