What’s Vulnerable › Vulnerabilities
CVE-2025-3583: Newsletter < 8.7.1 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-05 · updated 2026-06-17
- Weakness: CWE-79
Description
The Newsletter WordPress plugin before 8.7.1 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Affected products
- satollo Newsletter – Send awesome emails from WordPress: before 8.7.1 — fixed in 8.7.1
How to fix
Upgrade to a fixed version: satollo Newsletter – Send awesome emails from WordPress 8.7.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-3583 or the next vulnerability affects your stack