What’s Vulnerable › Vulnerabilities
CVE-2025-3584: Newsletter < 8.8.2 - Admin+ Stored XSS via Subscription
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-06-03 · updated 2026-06-17
- Weakness: CWE-79
Description
The Newsletter WordPress plugin before 8.8.2 does not sanitise and escape some of its Subscription settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Affected products
- satollo Newsletter – Send awesome emails from WordPress: before 8.8.2 — fixed in 8.8.2
How to fix
Upgrade to a fixed version: satollo Newsletter – Send awesome emails from WordPress 8.8.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/76937bdd-7ffa-4b5e-ade1-60da095a03a3/
- https://wpscan.com/vulnerability/76937bdd-7ffa-4b5e-ade1-60da095a03a3/
Get alerted when CVE-2025-3584 or the next vulnerability affects your stack