What’s Vulnerable › Vulnerabilities
CVE-2025-35983
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-10 · updated 2026-06-17
- Weakness: CWE-295
Description
Improper Certificate Validation (CWE-295) in the Controller 7000 OneLink implementation could allow an unprivileged attacker to perform a limited denial of service or perform privileged overrides during the initial configuration of the Controller, there is no risk for Controllers once they are connected. This issue affects Controller 7000: 9.30 prior to vCR9.30.250624a (distributed in 9.30.1871 (MR1)).
Affected products
- Gallagher Controller 7000: from 9.30 before vCR9.30.250624a — fixed in vCR9.30.250624a
How to fix
Upgrade to a fixed version: Gallagher Controller 7000 vCR9.30.250624a. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-35983 or the next vulnerability affects your stack