What’s Vulnerable › Vulnerabilities
CVE-2025-36038: IBM WebSphere Application Server code execution
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 13.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-25 · updated 2026-06-17
- Weakness: CWE-502
Description
IBM WebSphere Application Server 8.5 and 9.0 could allow a remote attacker to execute arbitrary code on the system with a specially crafted sequence of serialized objects.
Affected products
- IBM WebSphere Application Server: from 8.5 before 8.5.5.28; from 9.0 before 9.0.5.25 — fixed in 8.5.5.28, 9.0.5.25
How to fix
Upgrade to a fixed version: IBM WebSphere Application Server 8.5.5.28, 9.0.5.25. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-36038 or the next vulnerability affects your stack